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42 Kapitola 3 - Základní úlohy: vytvoření banneru, část 2

Vítejte v druhé části tohoto trojdílného úvodu do aplikace Macromedia Flash 
Basic 8 nebo Macromedia Flash Professional 8. Úspěšně jste dokončili první část 
tohoto návodu, v němž jste vytvořili, nastavili a importovali obsah do souboru 
typu FLA. Jelikož čtete druhou část, pravděpodobně jste připraveni dozvědět se 
o Flashi více. To je dobře, protože budete vytvářet symboly, animace, a dokonce 
psát nějaké jednoduché skripty v jazyce ActionScript, aby byl banner v tomto 
návodu na pokračování funkční. V této části přidáte banner na webovou stránku 
pomocí Dreamweaveru (nebo můžete nahrát banner na webový server pomocí 
jiného libovolného nástroje).

Popis první, druhé a třetí části tohoto návodu najdete v úvodu v části ,.Základní 
úlohy: vytvořem' banneru, část 1“ na straně 26.

K dokončení těchto návodů nepotřebujete žádné předchozí znalosti, nicméně než 
se pustíte do druhé části, měli byste dokončit část první (,.Základní úlohy: vytvo­
ření banneru, část 1“ na straně 26).

Ve druhé části tohoto návodu dokončíte následující úlohy:

Prohlížení hotového souboru typu FLA ................................................................. 43

Přidání textu ................................................................................................................44

Vytvoření symbolu .................................................................................................... 47

Přidání animace na časovou osu ..................................: ........................................48

Vytvoření tlačítka .......................................................................................................53

Napsání jednoduchých akcí .....................................................................................56

Testování aplikace .................................................................................................... 58

Pracovní postup tohoto návodu zahrnuje následující úlohy:

■ „Prohlížení hotového souboru typu FLA“ na straně 43 vám umožní zobrazit 
dokončený dokument Flashe pro část 2.

■ „Přidání textu“ na straně 44 vám ukáže, jak vytvořit a naformátovat text 
v souboru typu FLA.

■ „Vytvoření symbolu“ na straně 47 vás naučí vytvořit symbol klipu animace, 
do nějž přidáte animaci.

■ „Přidání animace na časovou osu“ na straně 48 vám umožní vytvořit anima­
ci pomocí hlavní časové osy a animace pohybem (motion tween).

■ „Vytvoření tlačítka“ na straně 53 vám předvede, jak vytvořit tlačítko, kterým 
vašemu banneru dodáte interaktivitu.

■ „Psaní jednoduchých akcí“ na straně 56 vám umožní napsat jednoduchý 
skript v jazyce ActionScript pro zajištění funkčnosti tlačítka.



60 Kapitola 4 - Základní úlohy: vytvorení banneru, část 3

Tohle je třetí část třídílné kapitoly o tom, jak vytvořit jednoduchý animovaný 
banner v aplikaci Macromedia Flash Basic 8 nebo Macromedia Flash Profes­
sional 8 a jak jej přidat na webovou stránku pomocí aplikace Macromedia Dre­
amweaver. V této poslední části se dozvíte o velikosti souboru, standardech 
bannerů, o provedení nastavení publikace, o tom, jak přidat banner na webo­
vou stránku Dreamweaveru a jak přidat detekci přehrávače Macromedia Flash 
Player.

K dokončení většiny třetí části tohoto návodu musíte mít nainstalovánu aplikaci 
Dreamweaver MX 2004 nebo Dreamweaver 8. Pokud Dreamweaver nepoužíváte, 
můžete dokončit první část této kapitoly a použít kód HTML, který vygeneruje 
Flash, v jiném editoru jazyka HTML. Nebudete si ovšem moci užít některé výhody 
při společném použití Flashe a Dreamweaveru.

Popis první, druhé a třetí části tohoto návodu najdete v úvodu v části „Základní 
úlohy: vytvoření banneru, část 1“ na straně 26.

K dokončení těchto návodů nepotřebujete žádné předchozí znalosti, nicméně 
než se pustíte do třetí části, měli byste dokončit první a druhou část tohoto 
návodu.

Ve třetí části tohoto návodu dokončíte následující úlohy:

Kontrola nastavení publikace ..................................................................................64

Vložení Flashe na web Dreamweaveru ................................................................. 66

Použití vlastnosti roundtrip editing ........................................................................ 68

Kontrola prehrávače Flash Player ...........................................................................69

Testováníaplikace .................................................................................................... 70

Pracovní postup tohoto návodu zahrnuje následující úlohy:

■ „Prohlížení hotového souboru typu FLA“ na straně 61 vám umožní zobrazit 
dokončený dokument Flashe pro část 3.

■ „Kontrola nastavení publikace“ na straně 64 vám ukáže, jak zkontrolovat 
a změnit vaše nastavení publikace před kompilací hotového banneru.

■ „Vložení Flashe na web Dreamweaveru“ na straně 66 vás naučí vložit ani­
maci Flashe na webovou stránku pomocí Dreamweaveru.

■ „Použití vlastnosti roundtrip editing“ na straně 68 vám umožní vrátit se do 
vývojového prostředí Flashe z Dreamweaveru, abyste provedli další úpravy 
vašeho souboru typu FLA.

■ „Kontrola přehrávače Flash Player“ na straně 69 vám předvede, jak přidat 
chování Dreamweaveru, které detekuje, zda vaši návštěvníci mají nainstalován 
přehrávač Flash Player.



74 Kapitola 5 - Základní úlohy: vytvoření přístupného obsahu ve Flashi

Se znalostí několika technik návrhu a zásad přístupnosti v aplikacích Macromedia 
Flash Basic 8 a Macromedia Flash Professional 8 můžete ve Flashi vytvořit obsah, 
který bude přístupný všem uživatelům, včetně těch s nějakým postižením.

Tato lekce demonstruje, jak vytvořit přístupný dokument navržený pro použití se 
čtečkami obrazovek (které nahlas čtou obsah webu pro slabozraké uživatele) 
a jinými pomocnými technologiemi.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky 
s dokumentací firmy Macromedia na adrese www.macromedia.com/go/fl_docu- 
mentatron.

V tomto návodu dokončíte následující úlohy:

Vytvoření dokumentu přístupného pro čtečky obrazovek .................................75

Vytvoření nadpisu a popisu dokumentu ..............................................................75

Vytvoření nadpisu a popisu pro instance ..............................................................75

Jak specifikovat, aby čtečky obrazovek ignorovaly prvky v dokumentu ..........76

Změna statického textu na dynamický text kvůli přístupnosti ..........................77

Kontrola pořadí prvků a pořadí čtení ...................................................................... 77

Tato lekce je úvodem k základním technikám.vytváření přístupného obsahu ve 
Flashi. Podrobné a vyčerpávající informace o integraci prvků přístupnosti do 
vašeho obsahu ve Flashi najdete v nápovědě Flashe v části „Creating Accessible 
Content“.

Nastavte si váš pracovní prostor
Nejprve otevřete výchozí soubor pro tuto lekci a nastavte si váš pracovní prostor 
tak, abyste při absolvování lekce využili optimální rozvržení.

1. Otevřete váš výchozí soubor, ve Flashi zvolte příkaz File > Open a najděte 
daný soubor:

■ Ve Windows najděte cestu bootovací jednotka Program Files\Macromedia\ 
Flash 8\Samples and Tutorials\Tutorial Assets\Basic Tasks\Create 
Accessible Content a poklepejte na soubor accessibility_start.fla.

■ Na Macintoshi najděte cestu Macintosh HD/Applications/Macromedia 
Flash 8/Samples and Tutorials/Tutorial Assets/Basic Tasks/Create 
Accessible Content a poklepejte na soubor acces.sibility_start.fla.

2. Zvolte příkaz File > Save As a uložte dokument pod novým jménem do stejné 
složky, abyste nepřepsali původní spouštěcí soubor.

http://www.macromedia.com/go/fl_docu-


82 Kapitola 6 - Základní úlohy: práce s vrstvami

V aplikacích Macromedia Flash 8 Basic a Macromedia Flash 8 Professional jsou 
vrstvy podobné průhledným fóliím umístěným jedna na druhé. V místech vrstvy, 
kde není žádný obsah, můžete vidět skrz na obsah ve vrstvách umístěných níže. 
Vrstvy slouží k uspořádání obsahu vašeho dokumentu. Například můžete mít gra­
fiku pozadí na jedné vrstvě a navigační tlačítka na jiné. Kromě toho můžete 
vytvářet a upravovat objekty na jedné vrstvě, aniž byste ovlivnili objekty na jiné 
vrstvě.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky s doku­
mentací firmy Macromedia na adrese www.macromedia.com/go/fl_documentation.

V tomto návodu dokončíte následující úlohy:

Výběr vrstvy ................................................................................................................ 83

Skrytí a zobrazení vrstev ........................................................................................... 84

Zamknutí vrstvy ......................................................................................................... 84

Přidání a pojmenování vrstvy ..................................................................................84

Změna pořadí vrstev .................................................................................................. 85

Uspořádání vrstev ve složce .................................................................................... 85

Přidání masky vrstvy ................................................................................................86

Přidání vodicích vrstev ......................................•................................................... 86

Odstranění vrstvy .......................................................................................................87

Nastavte si váš pracovní prostor
Nejprve otevřete výchozí soubor pro tuto lekci a nastavte si váš pracovní prostor 
tak, abyste při absolvování lekce využili optimální rozvržení.

1. Otevřete váš výchozí soubor, ve Flashi zvolte příkaz File > Open a najděte 
daný soubor:

■ Ve Windows najděte cestu bootovací jednotka\Program Files\Macromedia\ 
Flash 8\Samples and Tutorials\Tutorial Assets\Basic Tasks\Work with 
Layers a poklepejte na soubor layers_.start.fla.

■ Na Macintoshi najděte cestu Macintosh HD/Applications/Macromedia 
Flash 8/SampIes and Tutorials/Tutorial Assets/Basic Tasks/Work with 
Layers a poklepejte na soubor layers_start.fla.

POZNÁMKA

Složka Work with Layers obsahuje dokončenou verzi souborů typu FLA 
tohoto návodu pro vaši kontrolu.

- 

http://www.macromedia.com/go/fl_documentation


90 Kapitola 7 - Základní úlohy: vytvoření aplikace

Aplikace, kterou v této lekci vytvoříte, umožní uživatelům prohlédnout si cenu 
několika výrobků. Tlačítko Calculate poté přidá celkové náklady.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky 
s dokumentací firmy Macromedia na adrese www.macromedia.com/go/fl_docu- 
mentation.

V tomto návodu dokončíte následující úlohy:

Kopírování vstupních polí a dynamických textových polí .................................91

Pojmenování textových polí ....................................................................................91

Přidání a pojmenování komponenty Button ...........................................................92

Deklarace proměnných a cenových hodnot ........................................................ 92

Specifikace hodnot pro vstupní textová pole ........................................................ 93

Psaní funkcí ................................................................................................................ 93

Psaní obsluhy události pro komponentu ............................................................... 94

Nastavte si váš pracovní prostor
Nejprve otevřete výchozí soubor pro tuto lekci a nastavte si váš pracovní prostor 
tak, abyste při absolvování lekce využili optimální rozvržení.

1. Otevřete váš výchozí soubor, ve Flashi zvolte příkaz File > Open a najděte 
daný soubor:

■ Ve Windows najděte cestu bootovací jednotka Program Files\Macromedia\ 
Flash 8\Samples and Tutorials\Tutorial Assets\Basic Tasks\Create an 
Application a poklepejte na soubor calculator_start.fla.

■ Na Macintoshi najděte cestu Macintosh HD/Applications/Macromedia 
Flash 8/Samples and Tutorials/Tutorial Assets/Basic Tasks/Create an 
Application a poklepejte na soubor calculator_start.fla.

POZNÁMKA

Složka Create an Application obsahuje dokončenou verzi souborů typu FLA 
tohoto návodu pro vaši kontrolu.

2. Zvolte příkaz File > Save As a uložte dokument pod novým jménem, do stejné 
složky, abyste nepřepsali původní soubor.

POZNÁMKA

Během práce na této lekci nezapomeňte vaši práci pravidelně ukládat.

http://www.macromedia.com/go/fl_docu-


98 Kapitola 8 - Použití nástrojů pro rozmístění objektů na scéně

Macromedia Flash 8 Basic a Macromedia Flash 8 Professional nabízejí různé 
způsoby umístění objektů na ploše scény. Tento návod vás naučí, jak používat 
nástroje rozvržení ve Flashi k vytvoření uživatelského rozhraní.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky s doku­
mentací firmy Macromedia na adrese www.macromedia.com/go/fl_documentation.

V tomto návodu dokončíte následující úlohy:

Použití vodítek k zarovnání objektů ......................................................................99

Změna velikosti plochy scény ................................................................................100

Změna velikosti objektů, aby odpovídaly velikosti plochy scény ....................100

Nastavení přichytávání ............................................................................................101

Zarovnání objektu pomocí zarovnávacích vodítek ............................................. 101

Zarovnání objektů pomocí panelu Align ............................................................. 102

Vzájemné přichytávání objektů ..............................................................................102

Zarovnání objektů pomocí panelu Property inspector ...................................... 103

Zarovnání objektů pomocí mřížky a kurzorových kláves ................................. 104

Ačkoliv tato lekce využívá konkrétní nástroje pro jednotlivé typy objektů (např. 
zarovnávací vodítka pro zarovnání textu), neexistují žádná striktní pravidla, pokud 
jde o nejlepší způsob zarovnání konkrétního typu objektu. Ve vašich vlastních pro­
jektech použijte libovolné nástroje, které budou vyhovovat vašim potřebám.

Nastavte si váš pracovní prostor
Nejprve otevřete spouštěcí soubor pro tuto lekci a nastavte si váš pracovní prostor 
tak, abyste při absolvování lekce využili optimální rozvržení.

1. Otevřete váš spouštěcí soubor, ve Flashi zvolte příkaz File > Open a najděte 
daný soubor:

■ Ve Windows najděte cestu bootovací jednotka Program Files\Macromedia\ 
Flash 8\Samples and Tutorials\Tutorial Assets\Basic Tasks\Use Layout 
Tools a poklepejte na soubor layout_tools_start.fla.

■ Na Macintoshi najděte cestu Macintosh HD/Applications/Macromedia 
Flash 8/Samples and Tutorials/Tutorial Assets/Basic Tasks/Use Layout 
Tools a poklepejte na soubor layout_tools_start.fla.

POZNÁMKA

Složka Use Layout Tools obsahuje dokončenou verzi souborů typu FLA 
tohoto návodu pro vaši kontrolu.

http://www.macromedia.com/go/fl_documentation


108 Kapitola 9 - Základní úlohy: vytvoření symbolů a instancí

Symbol je opakovně použitelným objektem a instance je výskyt symbolu na ploše 
scény. Opakované použití instancí nezvětšuje velikost souboru a je dobrou sou­
částí strategie zachování malé velikosti projektu. Symboly rovněž zjednodušují 
úpravu dokumentu; když upravujete symbol, všechny instance tohoto symbolu se 
aktualizují tak, aby reflektovaly provedené změny. Další výhodou symbolů je to, 
že vám umožňují vytvářet sofistikovanou interaktivitu.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky 
s dokumentací firmy Macromedia na adrese www.macromedia.com/go/fl_docu- 
mentation.

V tomto návodu dokončíte následující úlohy:

Vytvoření grafického symbolu .............................................................................109

Duplikování a úpravainstance symbolu ........................................................110
Úpravasymbolu ......................................................................................................111

Vytvoření symbolu klipu animace ........................................................................111

Přiřazení jména instance klipu animace ...............................................................112

Přidání efektu do klipu animace .......................................................................... 112

Nastavte si váš pracovní prostor
Nejprve otevřete výchozí soubor pro tuto lekci a nastavte si váš pracovní prostor 
tak, abyste při absolvování lekce využili optimální rozvržení.

1. Otevřete váš výchozí soubor, ve Flashi zvolte příkaz File > Open a najděte 
daný soubor:

■ Ve Windows najděte cestu bootovací jednotka Program Files\Macromedia\ 
Flash 8\Samples and Tutorials\Tutorial Assets\Basic Tasks\Create 
Symbols and Instances a poklepejte na soubor symbols_start.fla.

■ Na Macintoshi najděte cestu Macintosh HD/Applications/Macromedia 
Flash 8/Samples and Tutorials/Tutorial Assets/Basic Tasks/Create 
Symbols and Instances a poklepejte na soubor symbols_start.fla.

POZNÁMKA

Složka Create Symbols and Instances obsahuje dokončenou verzi souborů 
typu FLA tohoto návodu pro vaši kontrolu.

Dokument se otevře ve vývojovém prostředí Flashe.

2. Zvolte příkaz File > Save As a uložte dokument pod novým jménem, do stej­
né složky, abyste nepřepsali původní soubor.

Během práce na této lekci nezapomeňte vaši práci pravidelně ukládat.

http://www.macromedia.com/go/fl_docu-mentation


116 Kapitola 10 - Základní úlohy: přidání animace tlačítka a navigace

Tlačítko je symbolem, který obsahuje speciální snímky pro různé stavy tlačítka, 
jako např. když se ukazatel myši uživatele nachází nad tlačítkem nebo když uživatel 
klepne na tlačítko. Když pro nový symbol vyberete jako behavior (typ chování) 
button, Macromedia Flash 8 Basic a Macromedia Flash 8 Professional 8 vytvoří 
pro stavy tlačítka časovou osu. K tlačítkům můžete přidat navigaci, a to pomo­
cí chování nebo napsáním ActionScriptu.

Tento návod vás naučí vytvářet a modifikovat tlačítka, včetně přidání animace na 
tlačítko.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky 
s dokumentací firmy Macromedia na adrese www.macromedia.com/go/fl_docu- 
mentation.

V tomto návodu dokončíte následující úlohy:

Vytvoření tlačítka ze seskupených objektu ........................................................ 117

Pojmenování instance tlačítka ............................................................................... 117

Zobrazení oblasti zásahu povolením tlačítek ......................................................118

Změna oblasti zásahu tlačítka ............................................................................... 118

Zarovnání tlačítek ....................................................................................................119

Vytvoření animace pro stav tlačítka .................  120

Přidání akcektlačítku ...........................................................................................120

Přidání navigacektlačítku ....................................................................................121

Testování souboru typu SWF ............................................................................... 122

Pokud nejste se symboly a instancemi dobře obeznámeni, před započetím této 
lekce zvolte příkaz Help > How Do I > Basic Flash > Create Symbols and Instan­
ces, kde se o nich dozvíte více.

Nastavte si váš pracovní prostor
Nejprve otevřete výchozí soubor pro tuto lekci a nastavte si váš pracovní prostor 
tak, abyste při absolvování lekce využili optimální rozvržení.

1. Otevřete váš výchozí soubor, ve Flashi zvolte příkaz File > Open a najděte 
daný soubor:

■ Ve Windows najděte cestu bootovací jednotka Program Files\Macromedia\ 
Flash 8\Samples and Tutorials\Tutorial Assets\Basic Tasks\Add Button 
Animation and Navigation a poklepejte na soubor buttons_start.fla.

■ Na Macintoshi najděte cestu Macintosh HD/Applications/Macromedia 
Flash 8/Samples and Tutorials/Tutorial Assets/Basic Tasks/Add Button 
Animation and Navigation a poklepejte na soubor button.s_start.fia.

http://www.macromedia.com/go/fl_docu-mentation


124 Kapitola 11 - Základní úlohy: vytvoření prezentace s obrazovkami

Flash 8 Professional nabízí nový způsob vytváření prezentací s obrazovkami 
snímků. Pokud si dokážete představit umístění médií na obrazovky snímků, při­
dání vnořených snímků, které dědí obsah z jiných snímků, a použití vestavěných 
ovládacích prvků pro navigaci mezi snímky v době běhu, pak máte přesnou před­
stavu o tom, jak snadné je vytvoření prezentace s obrazovkami snímků.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky s doku­
mentací firmy Macromedia na adrese www.macromedia.com/go/fl_documentation.

V tomto návodu dokončíte následující úlohy:

Přidání obsahu do snímku prezentace ................................................................. 126

Přidání chování navigace obrazovky tlačítkům ................................................. 127

Přidání a pojmenování snímku ............................................................................. 127

Výběr a přesun snímků ...........................................................................................128

Přidání obsahu do nového snímku ........................................................................ 128

Přidání chování přechodu ...................................................................................... 129

Nastavte si váš pracovní prostor
Nejprve otevřete výchozí soubor pro tuto lekci a nastavte si váš pracovní prostor 
tak, abyste při absolvování lekce využili optimální rozvržení.

1. Otevřete váš výchozí soubor, ve Flashi zvolte příkaz File > Open a najděte 
daný soubor:

■ Ve Windows najděte cestu bootovací jednotka Program Files\Macromedia\ 
Flash 8\Samples and Tutorials\Tutorial Assets\Basic Tasks\Presentation 
with Screens a poklepejte na soubor presentation_start.fla.

■ Na Macintoshi najděte cestu Macintosh HD/Applications/Macromedia 
Flash 8/Samples and Tutorials/Tutorial Assets/Basic Tasks/Presentation 
with Screens a poklepejte na soubor presentation_start.fla.

POZNÁMKA

Složka Presentation with Screens obsahuje dokončenou verzi souborů typu 
FLA tohoto návodu pro vaši kontrolu.

Dokument se otevře ve vývojovém prostředí Flashe.

2. Zvolte příkaz File > Save As a uložte dokument pod novým jménem, do stejné 
složky, abyste nepřepsali původní soubor.

Během práce na této lekci nezapomeňte vaši práci pravidelně ukládat.

3. Zvolte příkaz Window > Workspace Layout > Default, abyste nastavili pra­
covní prostor pro absolvování lekcí.

http://www.macromedia.com/go/fl_documentation


132 Kapitola 12 - Vytváření grafiky: kreslení ve Flashi

Když kreslíte ve Flashi, vytváříte vektorovou grafiku, což je matematická repre­
zentace čar, křivek, barev a umístění. Vektorová grafika je nezávislá na rozlišení; 
můžete libovolně měnit rozměry takovéto grafiky bez ztráty přesnosti. Vektorová 
grafika se stahuje rychleji než srovnatelné bitmapové obrázky. Tento návod vám 
prozradí, jak vytvořit vektorovou grafiku matice šroubu a loga.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky 
s dokumentací firmy Macromedia na adrese www.macromedia.com/go/fl_docu- 
mentation.

V tomto návodu dokončíte následující úlohy:

Kreslení mnohoúhelníku .........................................................................................134

Otočení tvaru ...........................................................................................................134

Použití vlastnosti vyříznutí ....................................................................................134

Transformace tvaru vaší kresby ............................................................................. 135

Kopírování tahů ...................................................................................................... 135

Kreslení pomocí nástroje Line .............................................................................136

Výběr a přidání jiné barvy výplně ........................................................................ 136

Seskupení tvaru ...................................................................................................... 136

Vytvoření loga pomocí nástroje Pen ...*.......................................................... 137

Nastavte si váš pracovní prostor
Nejprve otevřete výchozí soubor pro tuto lekci a nastavte si váš pracovní prostor 
tak, abyste při absolvování lekce využili optimální rozvržení.

1. Otevřete váš výchozí soubor, ve Flashi zvolte příkaz File > Open a najděte 
daný soubor:

■ Ve Windows najděte cestu bootovací jednotka Program Files\Macromedia\ 
Flash 8\Samples and Tutorials\Tutorial Assets\Creating Graphics\Draw 
in Flash a poklepejte na soubor drawing_start.fla.

■ Na Macintoshi najděte cestu Macintosh HD/Applications/Macromedia 
Flash 8/Samples and Tutorials/Tutorial Assets/Creating Graphics/Draw 
in Flash a poklepejte na soubor drawing_start.fla.

POZNÁMKA

Složka Draw in Flash obsahuje dokončenou verzi souborů typu FLA tohoto 
návodu pro vaši kontrolu.

Dokument se otevře ve vývojovém prostředí Flashe.
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140 Kapitola 13 - Vytváření grafiky: vytvoření animace na časové ose

Aplikace Macromedia Flash Basic 8 a Macromedia Flash Professional 8 obsahují 
mocné nástroje pro vytváření animací. Většina jednoduchých animací ve Flashi je 
vytvořena pomocí procesu zvaného tweening (pohybové vykreslení). Výraz tweening 
vznikl zkrácením ang. slov „in between“ (= uprostřed) a spočívá v doplnění snímků 
mezi dva klíčové snímky tak, aby se grafika zobrazená na prvním klíčovém snímku 
změnila postupně v grafiku zobrazenou na druhém klíčovém snímku.

Ve Flashi můžete vytvořit dva typy vykreslení - pohybové (motion tween) 
a tvarové (shape tween). Hlavní rozdíl mezi pohybovým a tvarovým vykreslením 
spočívá v tom, že pohybové vykreslení pracuje se seskupenými objekty nebo 
symboly, zatímco tvarové vykreslení se používá u objektů, které nejsou symboly 
a jsou neseskupeny.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky 
s dokumentací firmy Macromedia na adrese www.macromedia.com/go/fl_docu- 
mentation.

V tomto návodu dokončíte následující úlohy:

Vytvoření pohybového vykreslení .......................................................................141

Vytvoření tvarového vykreslení ......................................................................... 142

Kopírování a vložení klíčových snímků do animace ........................................143

Změna rychlosti animace ......................•............................................................. 145

Nastavte si váš pracovní prostor
Nejprve otevřete výchozí soubor pro tuto lekci a nastavte si váš pracovní prostor 
tak, abyste při absolvování lekce využili optimální rozvržení.

1. Otevřete váš výchozí soubor, ve Flashi zvolte příkaz File > Open a najděte 
daný soubor:

■ Ve Windows najděte cestu bootovací jednotka Program Files\Macromedia\ 
Flash 8\Samples and Tutorials\Tutorial Assets\Creating Graphics) 
Timeline Animation a poklepejte na soubor animation_.start.fla.

■ Na Macintoshi najděte cestu Macintosh HD/Applications/Macromedia 
Flash 8/Samples and Tutorials/Tutorial Assets/Creating Graphics/ 
Timeline Animation a poklepejte na soubor animation_start.fla.

POZNÁMKA

Složka Timeline Animation obsahuje dokončenou verzi souborů typu FLA 
tohoto návodu pro vaši kontrolu.

http://www.macromedia.com/go/fl_docu-mentation


140 Kapitola 14 - Vytvareni grafiky: animace pomoci zrychlení/zpomalení

Tento návod vás provede procesem použití nástrojů vykreslení v aplikacích Mac­
romedia Flash Basic 8 a Macromedia Flash Professional 8. Vykreslení (tweening) 
je proces animace grafiky nastavením počátečních a koncových hodnot jejích 
vlastností, přičemž Flash dopočítá hodnoty mezi těmito dvěma krajními body. 
Ang. výraz tween pochází ze slov „in between“ (z ang. mezi).

Jednoduchým příkladem pohybového vykreslení by bylo umístění grafiky do 
horní části plochy scény a poté přidání několika snímků na časovou osu a na 
posledním snímku přemístění grafiky do dolní části plochy scény. Tím, že Flash 
necháte doplnit hodnoty umístění pro snímky mezi prvním a posledním snímkem, 
můžete snadno vytvořit plynulou animaci grafiky z horní části plochy scény do 
dolní.

Flash Professional vám rovněž umožní plně kontrolovat výpočet hodnot vlast­
ností vykreslení, takže můžete snadno vytvořit složitější animace. Prostřednictvím 
okna Custom Ease In / Ease Out můžete kontrolovat rychlost, jíž jsou aplikovány 
změny vlastností na začátku a na konci vašich animací. Pečlivé použití tohoto 
okna může přinést vizuálně působivé výsledky.

Tento návod vás provede procesem vytvoření animací pomocí různých vlastností 
vykreslení grafiky s využitím různých ovládacích prvků ve vývojovém prostředí 
Flashe.

Po vyzkoušení již dokončené animace začnete otevřením výchozího dokumentu 
Flashe a skončíte publikováním dokumentu určeného pro přehrání na webu.

Dokončení tohoto návodu by vám mělo trvat přibližně 20 minut.

Než se do tohoto návodu pustíte, měli byste si přečíst kapitolu „Flash Basics“ 
v nápovědě Flashe.

V tomto návodu dokončíte následující úlohy:

Prohlížení hotového souboru typu FLA ................................................................149

Otevření spouštěcího dokumentu ......................................................................... 151

Vytvoření pohybového vykreslení ......................................................................... 151

Použití ovládacích prvků Ease ..............................................................................153

Vytvoření pohybového vykreslení s nastavením úrovně alfa ...........................159

Testování aplikace ...................................................................................................160

Pracovní postup tohoto návodu týkajícího se vykreslování zahrnuje následující úlohy:

■ „Prohlížení hotového souboru typu FLA“ na straně 149 vám umožní pro­
hlédnout si hotový dokument ve Flashi. Během tohoto procesu pochopíte 
způsob vytvoření animace i to, co budete v tomto návodu vytvářet.



162 Kapitola 15 - Vytváření grafiky: použití přechodů

Tento návod vás provede procesem použití nástrojů pro vytváření barevných pře­
chodů v aplikacích Macromedia Flash Basic 8 a Macromedia Flash Professional 
8. Ve Flashi můžete vytvářet jednoduché barevné přechody i složité přechodové 
efekty. V tomto návodu se naučíte vytvářet obojí.

Přechod je oblast grafiky, v níž jedna barva přechází do jiné barvy. Flash umí 
vytvořit dva hlavní typy přechodů - lineární a radiální. Lineární přechody mění 
barvu podél jedné osy, např. vodorovné či svislé. Radiální přechod mění barvu 
směrem ven, přičemž začne od ohniska. Směr přechodu můžete přizpůsobit stejně 
jako jeho barvu, umístění ohniska a mnoho dalších vlastností přechodů.

Následující ilustrace zobrazuje dva typy přechodů:

Dvoubarevný lineární přechod z červené do černé.

Dvoubarevný radiální přechod z červené do černé.

Tento návod vás provede kroky potřebnými k vytvoření ilustrace využívající 
vybrané přechody.

Po prohlédnutí vytvořené ilustrace začnete otevřením výchozího dokumentu ve 
Flashi a skončíte publikací dokumentu určeného pro přehrání na webu. Dokončení 
tohoto návodu by vám mělo trvat přibližně 20 minut.

Než se do tohoto návodu pustíte, měli byste si přečíst kapitolu „Flash Basics“ 
v nápovědě Flashe.

V tomto návodu dokončíte následující úlohy:

Prohlížení hotového souboru typu FLA ................................................................163

Otevření výchozího dokumentu ........................................................................... 165

Použití lineárního přechodu .................................................................................. 165

Vytvoření radiálního přechodu ..............................................................................166

Provedení posledních úprav ...................................................................................169

Testování aplikace ...................................................................................................172



174 Kapitola 16 - Vytváření grafiky: použití grafických filtrů a prolnutí

Tento návod vás provede procesem vytvoření poutavých grafických efektů pomocí 
některých prostředků v aplikacích Macromedia Flash Professional 8 (filtry nejsou 
ve verzi Flash Basic dostupné). Použitím grafických filtrů a režimů prolnutí, které 
Flash nabízí, můžete transformovat běžné grafické objekty na vizuálně podmanivější 
obsah.

Grafický filtr je metoda zpracování obrazových bodů grafického objektu, která 
vede k vytvoření patřičného efektu. Například můžete na nějaký objekt aplikovat 
filtr rozostření, aby byly jeho obrysy měkčí, nebo můžete na nějaký objekt apli­
kovat filtr vržený stín, aby se daný objekt zobrazil společně se stínem v pozadí.

Režim prolnutí je metoda vytvoření interakce barev grafického objektu s barvami 
jiného grafického objektu umístěného pod ním. Například pomocí režimu prolnutí 
Lighten můžete docílit toho, aby se části objektu zobrazily světlejší, v závislosti 
na barvách objektů pod ním.

Pokud jste tak již neučinili, společnost Macromedia vám doporučuje, abyste si 
před tímto návodem přečetli kapitolu „Flash Basics“ v nápovědě Flashe.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky 
s dokumentací firmy Macromedia na adrese www.macromedia.com/go/fl_docu- 
mentation.

V tomto návodu dokončíte následující ulohy:

Prohlížení vaší úlohy .............................................................................................. 174

Otevření výchozího dokumentu ........................................................................... 175

Použití filtrů a prolnutí ............................................................................................175 

Prohlížení vaší úlohy
V tomto návodu přidáte na plochu scény grafické objekty a aplikujete na ně filtry, 
abyste vytvořili realisticky vyhlížející obrázek kulečníkového stolu s určitou 
hloubkou pozadí. Koule v popředí a pozadí budou vypadat nezaostřené, jako by 
jste se na ně dívali skrze fotoaparát.

Abyste si prohlédli dokončený soubor typu FLA (Filters&Blends_finished.fla), 
najděte jedno z následujících umístění:

■ Ve Windows: bootovací jednotka Program Files\Macromedia\Flash 8\ 
Samples and Tutorials\Tutorial Assets\Creating Graphics\Filters and Blends.

■ Na Macintoshi: bootovací jednotka/ Applications/Macromedia Flash 8/ 
Samples and Tutorials/Tutorial Assets/Creating Graphics/Filters and Blends.

http://www.macromedia.com/go/fl_docu-mentation


180 Kapitola 17 - Text: přidání textu do dokumentu

Macromedia Flash Basic 8 a Macromedia Flash Professional 8 nabízí různé funk­
ce a možnosti nastavení textu. Tato lekce vám představí tři hlavní typy textu, které 
můžete přidat do dokumentu. Můžete přidat statický text pro nadpisy, popisky 
nebo jiný textový obsah, který chcete zobrazit v dokumentu. Rovněž můžete pou­
žít možnosti vstupního textu, abyste uživatelům umožnili interakci s vaší aplika­
cí ve Flashi - například aby zadali své jméno nebo další informaci ve formuláři. 
Třetím typem textu je dynamický text. Dynamická textová pole použijte k zobra­
zení textu, který se mění na základě specifikovaných kritérií. Například byste 
mohli použít dynamické textové pole pro sečtení hodnot uložených v jiných tex­
tových polích. Tento návod vás naučí, jak přidat text a textová pole do dokumen­
tu ve Flashi.

Po dokončení této lekce si určitě projděte další možnosti zpracování textu popsa­
né v části „Working with Text“ v nápovědě Flashe.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky s doku­
mentací firmy Macromedia na adrese www.macromedia.com/go/fl_documentation.

V tomto navodu dokončíte následující ulohy:

Nastavení pracovního prostoru ..............................................................................180

Vytvoření bloku textu s proměnlivou šířkou ..................................................... 181

Vytvoření bloku textu s pevnou šířkou ............................................................ 182

Úprava textu a změna atributů písma .................................................................. 183

Výběr systémových fontů .......................................................................................183

Přidání vstupního textového pole .........................................................................184

Kopírování textového pole .....................................................................................184

Přiřazení jmen instancí textovým polím ............................................................. 185

Vytvoření dynamického textového pole ............................................................. 185

Specifikace možností formátování ......................................................................... 186

Zobrazení ActionScriptu dynamického textového pole ....................................186

Testování souboru typu SWF ................................................................................ 187

Kontrola pravopisu ...................................................................................................187

Nastavte si váš pracovní prostor
Nejprve otevřete výchozí soubor pro tuto lekci a nastavte si váš pracovní prostor 
tak, abyste při absolvování lekce využili optimální rozvržení.

1. Otevřete váš výchozí soubor, ve Flashi zvolte příkaz File > Open a najděte 
daný soubor:

■ Ve Windows najděte cestu bootovací jednotka Program Files\ 
Macromedia\Flash 8\Samples and Tutorials\Tutorial Assets\ 
Text\Add Text to a Document a poklepejte na soubor text_start.fla.

http://www.macromedia.com/go/fl_documentation


190 Kapitola 18 - ActionScript: použití režimu Script Assist

Tento návod vás provede použitím režimu Script Assist v aplikacích Macromedia 
Flash Basic 8 a Macromedia Flash Professional 8.

Režim Script Assist vás vyzve k zadání prvků skriptu a pomůže vám jednodušeji 
přidat jednoduchou interaktivitu do vašeho souboru typu SWF (což je zkomprimovaná 
verze flashového souboru typu .fla s příponou .swf) nebo do aplikace. Režim Script 
Assist je ideální pro uživatele, kterým buď nevyhovuje psaní vlastních skriptů nebo 
kteří prostě oceňují jednoduchost použití tohoto nástroje.

Je-li režim Script Assist použit společně s panelem Actions, vyzve vás k výběru 
možností a zadání parametrů. Například místo abyste psali váš vlastní skript, 
můžete vybrat prvek ActionScriptu z panelu nástrojů Actions (nebo pomocí pří­
kazu Add (+) na panelu nástrojů), přetáhnout jej na panel Script a poté použít 
režim Script Assist, který vám pomůže skript dokončit.

Tento návod vás provede procesem použití režimu Script Assist, díky kterému přidáte 
interaktivitu do vaší aplikace ve Flashi. Přidáte kód ActionScriptu k nějakému 
objektu (tlačítku) a ke snímkům na časové ose. Tento návod rovněž demonstruje 
některé dobré postupy pro přidání skriptů do vašeho dokumentu ve Flashi.

Jakmile si prohlédnete již vytvořenou aplikaci ve Flashi, začnete otevřením spou­
štěcího dokumentu ve Flashi a skončíte testováním interaktivity, kterou do vaší 
aplikace přidáte pomocí režimu Script Assist. Dokončení tohoto návodu by vám 
mělo trvat přibližně 20 minut.•

Než se do tohoto návodu pustíte, měli byste si přečíst kapitolu „Flash Basics“ 
v nápovědě Flashe.

V tomto návodu dokončíte následující úlohy:

Prohlížení hotového souboru typu FLA ...............................................................191

Otevření výchozího dokumentu .......................................................................... 192

Přidání skriptu k tlačítku pomocí režimu Script Assist ....................................193

Přidání skriptů ke snímku na časové ose pomocí režimu Script Assist .......... 197

Přidání skriptu ke snímku klipu animace Title ....................................................199

Návod v této kapitole dodržuje typický pracovní postup při vytváření aplikace ve 
Flashi. Jiné pracovní postupy jsou rovněž možné. Pracovní postup tohoto návodu 
zahrnuje následující úlohy:

■ „Prohlížení hotového souboru typu FLA" na straně 191 vás seznámí s mož­
ností prohlédnout si hotový dokument ve Flashi.

■ „Otevření výchozího dokumentu“ na straně 192 vám umožní pustit se do 
návodu společně se souborem typu FLA (soubor Flashe s příponou .fla), 
který již obsahuje prvky využitelné v režimu Script Assist pro přidání 
ActionScriptu.



204 Kapitola 19 - Actionscript: přidání interaktivity

Macromedia Flash Basic 8 a Macromedia Flash Professional 8 nabízí nesčetně 
způsobů, jak nabídnout uživatelům interaktivitu. Když přidáte interaktivitu, nejste 
omezeni postupným přehráváním všech snímků na časové ose; i když postupné 
přehrávání nabízí lepší možnosti návrhu a tvorby. Tento návod vám ukáže některé 
ze způsobů začlenění interaktivity ve Flashi.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky s doku­
mentací firmy Macromedia na adrese www.macromedia.com/go/fl_documentation.

V tomto návodu dokončíte následující úlohy:

Nastavení pracovního prostoru ............................................................................. 204

Pojmenování instancí tlačítek ................................................................................205

Přidání scény ............................................................................................................206

Navigace mezi scénami ........................................................................................... 206

Řízení dokumentu pomocí akce stop() ...........................................................206

Provázání tlačítka se scénou ..................................................................................207

Přidání navigace pro návrat na scénu 1 ............................................................... 207

Přehrání klipu animace ........................................................................................... 208

Použití chování pro přehrání souboru typu MP3 ...............................................210

Testování dokumentu ..............................................................................................211

POZNÁMKA

Pokud máte verzi Flash Professional 8, můžete k vytvoření dokumentu použít 
obrazovky. Obrazovky nabízí další možnosti navigace. Například obrazovky 
snímků již zahrnují vestavěnou navigaci, která uživatelům umožňuje použít 
kurzorové klávesy k pohybu mezi obrazovkami. Více informací o obrazov­
kách najdete pod příkazem Help > Flash Tutorials > Basic Tasks: Create 
a Presentation with Screens (Flash Professional Only).

Nastavte si váš pracovní prostor
Nejprve otevřete výchozí soubor pro tuto lekci a nastavte si váš pracovní prostor 
tak, abyste při absolvování lekce využili optimální rozvržení.

1. Otevřete váš výchozí soubor, ve Flashi zvolte příkaz File > Open a najděte 
daný soubor:

■ Ve Windows najděte cestu bootovací jednotka Program Files\Macromedia\ 
Flash 8\Samples and Tutorials\Tutorial Assets\ActionScript\ 
Add Interactivity a poklepejte na soubor interactivity_start.fla.

http://www.macromedia.com/go/fl_documentation


214 Kapitola 20 - ActionScript: psaní skriptů

Jazyk ActionScript, který je součástí aplikací Macromedia Flash Basic 8 a Mac­
romedia Flash Professional 8, nabízí designérům a vývojářům celou řadu výhod. 
Pomocí ActionScriptu můžete řídit přehrávání dokumentu v závislosti na určité 
události, jako např. uplynutí času či načtení dat; můžete do dokumentu přidat 
interaktivitu v závislosti na chování uživatele, např. klepnutí na tlačítko; můžete 
použít vestavěné objekty, jako např. tlačítka s vestavěnými asociovanými metoda­
mi, vlastnostmi a událostmi; můžete vytvářet vlastní třídy a objekty; a můžete 
vytvářet kompaktnější a efektivnější aplikace, než bylo možné pomocí nástrojů 
uživatelského rozhraní, a to všechno s kódem, jejž můžete opětovně použít.

ActionScript je objektově orientovaným skriptovacím jazykem nabízejícím kon­
trolu nad přehráváním obsahu ve Flashi. V následujících lekcích se dozvíte, jak 
se ActionScript vyvinul do verze ActionScript 2.0, která obsahuje drtivou většinu 
prvků jazyka usnadňujících tvorbu objektově orientovaných programů.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky 
s dokumentací firmy Macromedia na adrese www.macromedia.com/go/fl_docu- 
mentation.

V tomto návodu dokončíte následující úlohy:

Nastavení pracovního prostoru ..............................................................................214

Vytvoření instance symbolu ...................................................................................215

Pojmenování instancí tlačítek ................................................................................ 216

Inicializace dokumentu ............................................................................................217

Použití syntaxe ActionScriptu ................................................................................ 218

Umístění referenční příručky ActionScriptu ...................................................... 218

Přidání komentářů do ActionScriptu .................................................................... 218

Psaní funkce pro tlačítko ..........................................................................................219

Kopírování a změna funkce pro tlačítko ..............................................................220

Kontrola syntaxe a testování vaší aplikace ........................................................... 220

Nastavte si váš pracovní prostor
Nejprve otevřete výchozí soubor pro tuto lekci a nastavte si váš pracovní prostor 
tak, abyste při absolvování lekce využili optimální rozvržení.

1. Otevřete váš výchozí soubor, ve Flashi zvolte příkaz File > Open a najděte 
daný soubor:

■ Ve Windows najděte cestu bootovací jednotka Program Files\Macromedia\ 
Flash 8\Samples and Tutorials\Tutorial Assets\ActionScript\Write Scripts 
a poklepejte na soubor scripts_start.fla.

http://www.macromedia.com/go/fl_docu-mentation


224 Kapitola 21 - ActionScript: formuláře s podmíněnou logikou...

Můžete vytvořit formulář s podmíněnou logikou, který umožní souboru typu SWF 
odpovědět na interakci uživatele a odeslat formulářová data ze souboru typu SWF 
externímu zdroji. Tento návod vám ukáže, jak vytvořit takový jednoduchý formulář. 

Než se pustíte do této lekce, měli byste být obeznámeni s psaním funkcí 
a proměnných; více se o této problematice dozvíte v nápovědě, kterou vyvoláte 
pomocí nabídky Help > Flash Tutorials > Basic Tasks: Create an Application.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky 
s dokumentací firmy Macromedia na adrese www.macromedia.com/go/fl_docu- 
mentation.

V tomto návodu dokončíte následující úlohy:

Nastavení pracovního prostoru .............................................................................. 224

Přidání vstupního textového pole pro sběr formulářových dat ........................225

Přidání tlačítka pro odeslání formuláře ................................................................226

Přidání chybové zprávy ............................................................................................ 226

Přidání potvrzovací zprávy ..................................................................................... 227

Přidání akce stopo ................................................................................................... 227

Přidání popisek rámců pro navigaci .....................................................................228

Přidání podmíněné logiky pro tlačítko pro odeslání ...........................................229

Předání dat ze souboru typu SWF ......................................................................... 230

Vytvoření funkce pro tlačítko Try Again ..............................................................231

Testování souboru typu SWF .................................................................................231

Nastavte si váš pracovní prostor
Nejprve otevřete výchozí soubor pro tuto lekci a nastavte si váš pracovní prostor 
tak, abyste při absolvování lekce využili optimální rozvržení.

1. Otevřete váš výchozí soubor, ve Flashi zvolte příkaz File > Open a najděte 
daný soubor:

■ Ve Windows najděte cestu bootovací jednotka Program Files\Macromedia\ 
Flash 8\Samples and Tutorials\Tutorial Assets\ActionScript\Create 
a Form a poklepejte na soubor simpleForm_start.fla.

■ Na Macintoshi najděte cestu Macintosh HD/Applications/Macromedia/ 
Flash 8/Samples and Tutorials/Tutorial Assets/ActionScript/Create a Form
a poklepejte na soubor simpleForm_.start.fla.

http://www.macromedia.com/go/fl_docu-


234 Kapitola 22 - ActionScript: práce s objekty a třídami

Třídy jsou v aplikacích Macromedia Flash Basic 8 a Macromedia Flash Professi­
onal 8 synonymem pro objekty. Všechny objekty ve Flashi mají základní třídu; 
například všechny klipy animací mají metodu zvanou getURL() a tato metoda je 
definovaná v definici třídy pro klip animace. Flash obsahuje mnoho předdefino­
vaných tříd, jako např. třídu MovieClip, Array, Color či CheckBox. Tento návod 
vám ukáže, jak vytvářet a modifikovat třídy.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky s doku­
mentací firmy Macromedia na adrese www.macromedia.com/go/fl_documentation.

V tomto návodu dokončíte následující úlohy:

Nastavení pracovního prostoru .............................................................................. 234

Seznámení s třídami a typy objektů ....................................................................... 235

Vytvoření objektu z třídy ........................................................................................235

Vytvoření vlastní třídy .............................................................................................237

Vytvoření dvou objektů z třídy Product ..............................................................240

Seznámení s rozšiřujícími existujícími třídami .................................................. 241

Rozšíření třídy MovieClip pro vytvoření nové třídy .........................................242

POZNÁMKA -

Tento návod je určen pro vývojáře ve Flashi, kteří jsou obeznámeni se 
základními koncepty Flashe a ActionScriptu.

Nastavte si váš pracovní prostor
Nejprve otevřete výchozí soubor pro tuto lekci a nastavte si váš pracovní prostor 
tak, abyste při absolvování lekce využili optimální rozvržení.

1. Prohlédněte si dokončené soubory.

Tato lekce neobsahuje výchozí soubory. Najít můžete dokončené soubory 
handson1.fla, handson2.fla. hand.son3.fla, Product.as a Drag.as, což jsou pří­
klady souborů, které budete vytvářet v této lekci:

■ Ve Windows najděte cestu bootovací jednotka Program Files\Macromedia\ 
Flash 8\Samples and Tutorials\Tutorial Assets\ActionScript\Work with 
Objects and Classes.

■ Na Macintoshi najděte cestu Macintosh HD/Applications/Macromedia/ 
Flash 8/Samples and Tutorials/Tutorial Assets/ActionSeript/Work with 
Objects and Classes.

2. Zvolte příkaz Window > Workspace Layout > Default, abyste nastavili pra­
covní prostor pro absolvování lekcí.

http://www.macromedia.com/go/fl_documentation
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248 Kapitola 24 - Integrace dat: použití webové služby Macromedia Tips

V tomto návodu použijete panel Web Services k připojení k webové službě, kterou 
využijete k vrácení libovolného tipu o softwaru Macromedia. Poté použijete 
komponenty k nastavení jednoduchého uživatelského rozhraní.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky 
s dokumentací firmy Macromedia na adrese www.macromedia.com/go/fl_docu- 
mentation.

V tomto návodu dokončíte následující úlohy:

Připojení k veřejné webové službě ....................................................................... 248

Vytvoření uživatelského rozhraní a propojení komponent s webovou službou .. .250

Tento návod využívá veřejnou webovou službu, a proto vyžaduje připojení 
k Internetu.

Máte-li problémy se stahováním nebo rozbalením souborů, najděte si Technickou 
zprávu č. 13686 na adrese www.macromedia.com/support/general/ts/documents/ 
downfiles.htm.

POZNÁMKA

Použití veřejných webových služeb, v těchto návodech nepředpokládá, že 
byste je měli využít v reálných aplikacích. Firma Macromedia ani nedopo­
ručuje využívat veřejných webových služeb přímo z libovolné klientské apli­
kace. Více informací najdete v části „About data connectivity and security in 
Flash Player“ v kapitole „Data Integration“ v nápovědě Flashe (ve Flashi 
zvolte příkaz Help > Using Flash). V návrhovém prostředí byste měli použít 
webové služby, které se nachází na vašem vlastním webovém serveru.

Dokončený soubor typu FLA pro tento návod byl nainstalován s Flashem. Následující 
seznam uvádí typické cesty k tomuto adresáři.

■ Ve Windows najděte cestu bootovací jednotka Program Files\Macromedia\ 
Flash 8\Samples and Tutorials\Tutorial Assets\Data Integration\Tips.

■ Na Macintoshi najděte cestu Macintosh HD/Applications/Macromedia/ 
Flash 8/Samples and Tutorials/Tutorial Assets/Data Integration/Tips.

Připojení k veřejné webové službě
Definujte webovou službu ve Flashi, která se připojí k veřejné webové službě.

1. Vytvořte nový flashový dokument ve Flashi Professional 8. Přesvědčte se, že 
je váš počítač připojen k Internetu.

2. Otevřete panel Web Services (Window > Other Panels > Web Services) 
a klepněte na ikonu Define Web Services.

http://www.macromedia.com/go/fl_docu-mentation
http://www.macromedia.com/support/general/ts/documents/


256 Kapitola 25 - Integrace dat: použití XML

Tento návod vám ukáže, jak vytvořit aplikaci pro úpravu dat pracovního výkazu. 
Data pracovního výkazu jsou uložena ve formátu XML uvnitř nativní XML data­
báze. Komponenta XUpdateResolver je nejlepší volbou pro tento typ aplikace, 
neboť generuje příkazy jazyka XUpdate. které mohou být odeslány na server pro 
aktualizaci dat.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky 
s dokumentací firmy Macromedia na adrese www.macromedia.com/go/fl_docu- 
mentation.

V tomto návodu dokončíte následující úlohy:

Vytvoření uživatelského rozhraní .........................................................................257

Úpravadat ................................................................................................................. 263

Tento návod využívá veřejnou webovou službu, a proto vyžaduje připojení 
k Internetu. Kromě toho, tento návod nebude fungovat ve webovém prohlížeči, 
kvůli tzv. omezení sandboxu (chráněné prostředí operační paměti počítače, 
v němž mohou aplikace běžet bez rizika zásahu do samotného systému, pozn. 
překl.), ale bude fungovat ve vývojovém prostředí Flashe nebo samostatném pře­
hrávači Flash Player.

POZNÁMKA

Použití veřejných webových služeb v těchto návodech nepředpokládá, že 
byste je měli využít v reálných aplikacích. Firma Macromedia ani nedopo­
ručuje využívat veřejných webových služeb přímo z libovolné klientské apli­
kace. Více informací najdete v části „About data connectivity and security in 
Flash Player“ v nápovědě Flashe.

Pro tento návod budete potřebovat soubor data.xml, který se nachází ve složce 
Tutoriál Assets. Tento soubor můžete najít v jednom z následujících umístěni:

■ Ve Windows najděte cestu bootovací jednotka\Program Files\Macromedia\ 
Flash 8\Samples and Tutorials\Tutorial Assets\Data Integration\Using XML 
for a Timesheet\data.xml.

■ Na Macintoshi najděte cestu Macintosh HD/Applications/Macromedia/ 
Flash 8/Samples and Tutorials/Tutorial Assets/Data Integration/Using XML 
for a Timesheet/data.xml.

POZNÁMKA

Z důvodů předvádění zpřístupníte data XML z vaší Bootovací jednotky a zobra­
zíte vlastnost DeltaPacket na vaší obrazovce. Ve skutečnosti by byl příkaz 
jazyka XUpdate odeslán na server ke zpracování.

http://www.macromedia.com/go/fl_docu-mentation


266 Kapitola 26 - Integrace dat: použití XUpdate к aktualizaci výkazu

Předpoklad: kapitola „Integrace dat: použití XML pro vytvoření pracovního 
výkazu (pouze verze Flash Professional)“

Tento návod začíná v místě, kde končí kapitola „Integrace dat: použití XML pro 
vytvoření pracovního výkazu (pouze verze Flash Professional)“. Teď, když kom­
ponenta DataSet spravuje data, sleduje změny, které jsou na datech provedeny, 
ve vlastnosti DeltaPacket. Pro odeslání změn zpět na server optimalizovaným 
způsobem je potřeba synchronní přenos. Komponenta XUpdateResolver je nej­
lepší volbou pro aktualizaci zdroje XML, neboť generuje příkazy jazyka XUpda­
te, které mohou být odeslány na server a aktualizovat data.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky 
s dokumentací firmy Macromedia na adrese www.macromedia.com/go/fl_docu- 
mentation.

V tomto návodu dokončíte následující úlohy:

Aktualizace pracovního výkazu ............................................................................267

Tento návod využívá veřejnou webovou službu, a proto vyžaduje připojení 
k Internetu. Kromě toho, tento návod nebude fungovat ve webovém prohlížeči, 
kvůli tzv. omezení sandboxu (chráněné prostředí operační paměti počítače, 
v němž mohou aplikace běžet bez rizika zásahu do samotného systému, pozn. 
překl.), ale bude fungovat ve vývojovém prostředí Flashe nebo samostatném 
přehrávači Flash Player.

POZNÁMKA

Použití veřejných webových služeb v těchto návodech nepředpokládá, že 
byste je měli využít v reálných aplikacích. Firma Macromedia ani nedopo­
ručuje využívat veřejných webových služeb přímo z libovolné klientské apli­
kace. Více informací najdete v části „About data connectivity and security in 
Flash Player“ v nápovědě Flashe.

Pro tento návod budete potřebovat soubor data.xml, který se nachází ve složce 
Tutoria! Assets. Tento soubor můžete najít v jednom z následujících umístění:

■ Ve Windows najděte cestu bootovací jednotka Program Files\Macromedia\ 
Flash 8\Samples and Tutorials\Tutorial Assets\Data Integration\Using XML 
for a Timesheet\data.xml.

■ Na Macintoshi najděte cestu Macintosh HD/Applications/Macromedia/ 
Flash 8/Samples and Tutorials/Tutorial Assets/Data Integration/Using XML 
for a Timesheet/data.xml.

http://www.macromedia.com/go/fl_docu-mentation
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14 Kapitola 1 - Základní úlohy: vytvoření dokumentu

Chystáte se vyzkoušet možnosti programu Macromedia Flash Basic 8 a Macro­
media Flash Professional 8. Dozvíte se, jak během pár minut vytvořit působivý 
web kombinující ovládací prvky videa, textu, grafiky a médií.

Tento návod si můžete vytisknout jeho stažením ve formátu PDF ze stránky 
s dokumentací firmy Macromedia na adrese www.macromedia.com/go/fl_docu- 
mentation.

V tomto návodu dokončíte následující úlohy:

Přehled uživatelského rozhraní ................................................................................. 15

Nastavení panelu Select a přizpůsobení panelů .....................................................15

Změna pozadí a velikosti plochy scény ...................................................................17

Změna zobrazení plochy scény ................................................................................. 18

Zobrazení panelu Library ...........................................................................................18

Přidání grafiky na plochu scény ...............................................................................18

Přidání videa ................................................................................................................19

Zobrazení vlastností objektu ......................................................................................19

Přidání chování ovládacím prvkům videa (behaviors) ....................................... 20

Použití Prohlížeče animací k zobrazení struktury , dokumentu .......................... 21

Testování dokumentu ................................................................................................. 22

Nalezení nápovědy ......................................................................................................22

Před zahájením této lekce vám doporučujeme, abyste si přečetli průvodce Getting 
Started with Flash, v němž se dozvíte o pracovním prostoru ve Flashi. Tohoto 
průvodce najdete v nabídce Help > Getting Started with Flash.

http://www.macromedia.com/go/fl_docu-


26 Kapitola 2 - Základní úlohy: vytvoření banneru, část 1

Macromedia Flash Basic 8 nebo Macromedia Flash Professional 8 mohou půso­
bit jako velmi složité programy na to, abyste se s nimi naučili pracovat. Jedním 
z důvodů této zdánlivé složitosti je skutečnost, že jej můžete použít k celé řadě 
různých věcí, jako např. pro kreslené animace, přehrávače médií a sofistikovaný 
software. Tento návod je vhodný pro naprosté začátečníky, kteří pracují v programu 
Flash 8 poprvé. Ukáže vám některé základní aspekty programu i to, jak jej začít 
používat k vytváření skutečných projektů. Abyste dokončili tuto kapitolu, nemu­
síte o Flashi nebo animaci vědět vůbec nic; vlastně zjistíte, jak snadné je začít 
používat Flash 8 k přidání prvků na vaše webové stránky.

Tohle je první část třídílného návodu, který se věnuje se vytvoření jednoduchého 
animovaného banneru ve Flashi a jeho přidání na webovou stránku pomocí Mac­
romedia Dreamweaveru. V části 1 se dozvíte, jak vytvořit soubor a změnit jeho 
nastavení, jak importovat a přidat grafiku na plochu scény z knihovny a vytvořit 
vrstvy. V částech 2 a 3 přidáte animaci a vytvoříte tlačítko, které otevře okno 
prohlížeče. Poté specifikujete nastavení pro publikaci a přidáte banner na webo­
vou stránku.

„Základní úlohy: vytvoření banneru, část 1“ na straně 26: Naučíte se, jak vytvo­
řit a strukturovat banner.

„Základní úlohy: vytvoření banneru, část 2“ na straně 42: Naučíte se, jak přidat 
animaci, vytvořit tlačítko a napsat základní skripty.«

„Základní úlohy: vytvoření banneru, část 3“ na straně 60: Naučíte se, jak publi­
kovat váš soubor typu SWF a jak jej vložit na web v Dreamweaveru.

K dokončení těchto návodů nepotřebujete žádné předchozí znalosti.

V části 1 tohoto návodu dokončíte následující úlohy:

Prohlížení hotového souboru typu FLA .................................................................. 27

Vytvoření nového dokumentu ................................................................................... 28

Změna vlastností dokumentu ................................................................................... 30

Import grafiky ............................................................................................................. 32

Představení vrstev a časové osy ...............................................................................34

Testování aplikace ......................................................................................................38

Pracovní postup tohoto návodu obsahuje následující úlohy:

■ „Prohlížení hotového souboru typu FLA“ na straně 27 vám umožňuje pro­
hlédnout si hotový dokument ve Flashi.

■ „Vytvoření nového dokumentu“ na straně 28 vám ukáže, jak vytvořit soubor 
typu FLA, který ve třech částech tohoto návodu použijete k vytvoření banneru.


